OpenWRT rebase on final 21.02 release?


The OpenWRT release supportd by Traverse is based on 21.02 rc03.
Meanwhile, there has been rc04 and a final release for 21.02.

Could you please share whether there is a roadmap to rebase on the final release?

That would help for:



I’m looking forward as well to this.

I greatly appreciate the effort Matthew puts behind the release of these versions and happy to wait patiently for the release.

Do we also have a timeline for the integration of the Ten64 firmware into the official OpenWRT repository, as I’m guessing once this happens we will have access to all the standard package repositories.

A rebase on the 21.02 final release should be available in the next week or two. I had actually just finished -rc4 a day before the final release came out.

There is a bit of work involved as the 21.02 builds we distribute have the 5.10 kernel instead of 5.4 used in the official 21.02 release. (There is too much stuff we want in >=5.10 and/or would be too hard to bring back to 5.4) However, they should be binary compatible with 21.02 packages/ipks (excluding kernel modules). We expect to maintain this 21.02 “branch” going forward as a “stable” option for customers.

The main reason there is only a “minimal” package collection for our builds is to keep build times down (it takes about 1 hour to do the public builds at the moment, I don’t want it to go longer than that)

Happy to take package suggestions and add them for our users (and I have noted the ones mentioned on the forum already) and I think I can optimize our CI builds to have more caching as well.

I’m hoping to do a submission for OpenWrt in October or November. The reason it has not happened yet is that it involves a new “generic” arm64 target (not “layerscape”) for reasons explained on this openwrt-devel post. Now that 21.02 is out and 5.10 is moving to be the “default” kernel the timing is better now.


Thanks a lot for your feedback. Well, in term of package suggestion, if that package could be added I could then support my use case that requires DNETMAP (for IPv6 NPT on multi-wan IPV6 setup).

Thanks for all your work!

Hi all,
There is a build rebased on 21.02 final + kernel 5.10.64 now available.
You can use openwrt-arm64-efi-generic-ext4-combined.img.gz with OpenWrt’s sysupgrade.

I have not tested too intensively but its passed my basic checks. Should not be any major changes from previous -rc3/-rc4 builds.

If there are no issues I’ll make it the default OpenWrt appliance in a few days.


@mcbridematt could we get the same for muvirt?

Shall this work with NAND as well?

Apologies, not yet. I need to add support for generating NAND/ubifs to the OpenWrt tree.
Should be coming very soon.

That will be coming next week. On top of the rebase I’m rolling in various minor fixes (e.g GRUB falling back to built-in config) and additions (your UUID patch and more)

1 Like

There is now a 21.02 NAND image, download here.
It is not possible to upgrade directly directly from the older 5.4 NAND firmware but you can switch over in a couple of steps:

  1. Backup your current configuration by creating a backup from LuCI or by using sysupgrade -b sysupgrade.tgz

  2. From your existing OpenWrt NAND, or recovery firmware, download and write the image to the second OpenWrt slot:

     ubiformat /dev/mtd10 -f openwrt-arm64-ten64-mtd-ubifs-nand.ubi
     fw_setenv openwrt_active_sys b
  3. Reboot and it should boot into the new 5.10 based system. You can restore your config backup from LuCI or sysupgrade -r sysupgrade.tgz

If you need to switch back to the older system for some reason, you can use fw_setenv openwrt_active_sys a

All future upgrades for OpenWrt-NAND can use openwrt-arm64-ten64-mtd-ubifs-sysupgrade.tar with OpenWrt’s upgrade facility.

There is also a trick to copy the config backup directly into the new system (as if you upgraded it). If you are not 100% sure about what is going on here, stick to the method above of downloading and restoring

ubiformat /dev/mtd10 -f openwrt-arm64-ten64-mtd-ubifs-nand.ubi
ubiattach -m 10
mount -t ubifs ubi1:rootfs /mnt/
sysupgrade -b sysupgrade.tgz
cp sysupgrade.tgz /mnt/
umount /mnt
fw_setenv openwrt_active_sys b

Maybe someone will find this useful. I have updated, but I used UI to make backup and restore the configuration.

After restoring configuration, accessing UI was giving me

/usr/lib/lua/luci/dispatcher.lua:427: /etc/config/luci seems to be corrupt, unable to find section 'main'

I have solved this with

  1. Login to router with ssh.
  2. Edit /etc/config/rpcd to replace option socket /var/run/ubus.sock with option socket /var/run/ubus/ubus.sock.
  3. Restart httpd: service uhttpd restart
  4. Restart rpcd: service rpcd restart
1 Like

@mcbridematt Would it be possible to add netperf?

Will do!

In the meantime, you should be able to install the .ipk from

opkg install netperf_2.7.0-2_aarch64_generic.ipk

It seems to work ok:

MIGRATED TCP STREAM TEST from ( port 0 AF_INET to localhost (127.0.0) port 0 AF_INET : demo
Recv   Send    Send
Socket Socket  Message  Elapsed
Size   Size    Size     Time     Throughput
bytes  bytes   bytes    secs.    10^6bits/sec

131072  16384  16384    10.00    10146.41

@mcbridematt Thanks for the tip.

There is now an 21.02.1 version, if possible could we please get an update or if easier every 2nd release?

How’s the submission to OpenWRT progressing? So in future we will not need to bother you every time :slight_smile:

Can we please get ntpdate added, unfortunately can’t seem to compile this one, not sure if it’s the altered build or a trick to building this package. I like to monitor the time differences on openwrt and muvirt.

Next to this, I would also request ddns-scripts to be added, if possible (then it would cover all my use cases).

Thanks for all the work! :slight_smile:

I did actually upload a 21.02.1 version last week, but did not post about it. Sorry about that!

For muvirt, I want to fix a problem with it’s setup wizard on NAND before I update it (within the next week).

ddns-scripts was added to the package repository but not ntpdate yet.

Would ntpd -p -q -n -d work as a substitute for now?

I haven’t started putting together a submission yet, maybe before Christmas.

1 Like

@mcbridematt Just upgraded using sysupgrade image. It worked for me this time! :love_you_gesture:

UI says for firmware version OpenWrt 21.02-SNAPSHOT r0-6725504 / LuCI openwrt-21.02 branch git-21.324.73591-f3611f1 and kernel 5.10.76. I guess, looking at the kernel version, I am using 21.02.1 now.

Updating firmware version string would be great. :slight_smile:

Thank you, with a bit of bash string manipulation it works well :slight_smile:

I’m having trouble with installing kmod packages that I have built. I’m am building kmod-ipt-netflow
Opkg is reporting an issue with:
pkg_hash_check_unresolved: cannot find dependency kernel (= 5.10.82-1-a4043683d4709f4e4d5c9b450aefabb2)
and Checking kernel version
kernel - 5.10.82-1-b5bef3d4b31dc59739cc3fec5a69297b

Does this mean there is a discrepancy with the sdk kit and the image running?

Is there also any muvirt rebase to final 21.02 release already?